[tei-council] classy part

Sebastian Rahtz sebastian.rahtz at oucs.ox.ac.uk
Sun Oct 8 07:22:51 EDT 2006

Syd Bauman wrote:
> I propose 
> * create new class, att.partial, which declares part=
> * add all four above to new att.partial
> * drop part= from all four, as they now have it via inheritance 
good. but "att.partial" is an unfortunate name, as "partial" has
meaning not related to this use of "part".
"att.parted" is better (and like att.typed), but even more
unfortunate in some ways
> [1] This adds subtype= to <c>, <cl>, <m>, <phr>, <s>, and <w>. If I
>     understand correctly in P4 these elements did not have subtype=
>     because they were considered analogous to <seg type="phr">, e.g.
>     So <seg> had the subtype=, but not the others.
you could cut this Gordian knot by inventing att.subtyped
as a member of att.typed, moving @subtype to att.subtyped,
and moving the existing members of att.typed to att.subtyped.
It would be a little tedious, but clearer.

Sebastian Rahtz      

Information Manager, Oxford University Computing Services
13 Banbury Road, Oxford OX2 6NN. Phone +44 1865 283431

OSS Watch: JISC Open Source Advisory Service

More information about the tei-council mailing list