[tei-council] the "key" attribute
Matthew James Driscoll
mjd at hum.ku.dk
Tue May 22 07:50:02 EDT 2007
Yes, quite awake, but up to my oxters in work (by which I mean what I'm
actually paid to do). Still, I've been following this debate very closely,
for the reason you indicate, viz. that this issue is of such importance to
all this name stuff. Unfortunately, but not for the first time, I'm not sure
I understand the technical issues sufficiently to try and voice an opinion.
It would be helpful if I had a clearer idea of the difference between key,
ana and target (and ref), all of which seem to do similar, but subtly
different, things. It's the "subtly different" bit that gets me.
key "provides a means of locating a full definition for the entity being
named such as a database record key or a URI"
ana "indicates one or more elements containing interpretations of the
element on which the ana attribute appears"
target "specifies the destination of the reference by supplying one or more
ref "points to a description of the character or glyph intended"
The first of these is datatype data.key ("defines the range of attribute
values expressing a coded value by means of an arbitrary identifier,
typically taken from a set of externally-defined possibilities=), while the
last 3 are data.pointer ("defines the range of attribute values used to
provide a single pointer to any other resource, either within the current
document or elsewhere").
Anybody want to try to explain to me wherein the subtle difference lies?
From: tei-council-bounces at lists.village.Virginia.EDU
[mailto:tei-council-bounces at lists.village.Virginia.EDU] On Behalf Of
Sent: Tuesday, May 22, 2007 11:08 AM
To: Syd_Bauman at Brown.edu
Cc: TEI Council
Subject: Re: [tei-council] the "key" attribute
Syd Bauman wrote:
> I'm sorry, it is likely I have not been able to follow the
> conversation well enough from here, but could you define what an
> "object thing" is?
all the things which are members of att.naming
> And every project is going to use the
> non-URI keys differently. So this is not a place where
> interoperability concerns come into play.
ok, fair enough; we could allow both
> I also still think key= of <memberOf>, <moduleRef>, et al. should
> remain a "match the ident=" attribute, but should undergo a name
> change. I'm also still happy to consider leaving its name key=, and
> coming up with a better name for the use for naming elements.
OK, how about we do this:
- leave @key on <memberOf> etc as is
- change att.naming to remove @key and put in @ref as pointer instead
- discuss at places meeting next week whether they need the @key
and if so ask them to choose a name
Matthew, are you awake? do you have a view on this, as a big proponent
of keys on naming objects?
Information Manager, Oxford University Computing Services
13 Banbury Road, Oxford OX2 6NN. Phone +44 1865 283431
tei-council mailing list
tei-council at lists.village.Virginia.EDU
More information about the tei-council